{"answers":{"affected":"2 open source packages ship an affected version, including drupal/simple_multistep. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12761 in the wild and no public exploit code.","fix":"Upgrade drupal/simple_multistep to 2.0.0 or later.","what":"CVE-2025-12761 is a low-severity cross-site scripting vulnerability in Drupal Simple multi step form, published on 18 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-12761 and fix it if it is affected.\n\nWhat it is: CVE-2025-12761 is a low-severity cross-site scripting vulnerability in Drupal Simple multi step form, published on 18 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-12761 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/simple_multistep (Packagist): affected all versions; fixed in 2.0.0\n- drupal/simple_multistep (Packagist): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12761/ (Markdown: https://insights.sbomify.com/CVE-2025-12761/index.md)","id":"CVE-2025-12761","markdown":"https://insights.sbomify.com/CVE-2025-12761/index.md","name":"CVE-2025-12761","record":{"aliases":["DRUPAL-CONTRIB-2025-116","GHSA-gg35-374m-9ph8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal module","requires_auth":"high_privilege","summary":"Attackers can inject malicious scripts into Drupal pages via the Simple multi step form module, potentially stealing user data or hijacking sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"simple_multi_step_form","vendor":"simple_multi_step_form_project"}],"cvss":{"score":3.5,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (\"Cross-site Scripting\") vulnerability in Drupal Simple multi step form allows Cross-Site Scripting (XSS).This issue affects Simple multi step form: from 0.0.0 before 2.0.0.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Simple multi step form - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-116","id":"CVE-2025-12761","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)","id":"CVE-2025-12762"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"drupal/simple_multistep","purl":null,"source":"GHSA-gg35-374m-9ph8"},{"ecosystem":"Packagist","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"drupal/simple_multistep","purl":"pkg:composer/drupal/simple_multistep","source":"GHSA-gg35-374m-9ph8"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"drupal/simple_multistep","purl":"pkg:composer/drupal/simple_multistep?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-116"}],"prev":{"headline":"Email TFA - Moderately critical - Access bypass - SA-CONTRIB-2025-115","id":"CVE-2025-12760"},"products":["Simple multi step form"],"published":"2025-11-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-18","vendors":["Drupal"]},"summary":"Attackers can inject malicious scripts into Drupal pages via the Simple multi step form module, potentially stealing user data or hijacking sessions.","url":"https://insights.sbomify.com/CVE-2025-12761/"}