# CVE-2025-12761: Simple multi step form - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-116

> Attackers can inject malicious scripts into Drupal pages via the Simple multi step form module, potentially stealing user data or hijacking sessions.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 18 Nov 2025
- **Also known as:** DRUPAL-CONTRIB-2025-116, GHSA-gg35-374m-9ph8

## What is CVE-2025-12761?

CVE-2025-12761 is a low-severity cross-site scripting vulnerability in Drupal Simple multi step form, published on 18 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Simple multi step form allows Cross-Site Scripting (XSS).This issue affects Simple multi step form: from 0.0.0 before 2.0.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-12761?

2 open source packages ship an affected version, including drupal/simple_multistep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/simple_multistep` | Packagist | All versions | 2.0.0 |
| `drupal/simple_multistep` | Packagist | All versions | 2.0.0 |
| `drupal/simple_multistep` | Packagist:https://packages.drupal.org/8 | All versions | 2.0.0 |

Products: Simple Multi Step Form Project Simple Multi Step Form.

## How do I fix CVE-2025-12761?

Upgrade drupal/simple_multistep to 2.0.0 or later.

## Is CVE-2025-12761 being exploited?

There is no known exploitation of CVE-2025-12761 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12761 and fix it if it is affected.

What it is: CVE-2025-12761 is a low-severity cross-site scripting vulnerability in Drupal Simple multi step form, published on 18 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-12761 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/simple_multistep (Packagist): affected all versions; fixed in 2.0.0
- drupal/simple_multistep (Packagist): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12761/ (Markdown: https://insights.sbomify.com/CVE-2025-12761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12761
- OSV: https://osv.dev/vulnerability/CVE-2025-12761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12761/
Summaries are generated and may contain mistakes; the official description above is the record.
