CVE-2025-12762 Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)

Critical 9.1 Published Updated

Attackers can execute arbitrary commands on the server by restoring malicious PLAIN-format SQL dumps in pgAdmin 4 server mode.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12762?

CVE-2025-12762 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.

Weakness: CWE-94

Which versions are affected by CVE-2025-12762?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.

PackageAffectedFixed in
pgadmin4 PyPIAll versions9.10
pgadmin4 PyPIAll versions9.10
pgadmin4 PyPIAll versions9.10

Products include Pgadmin Pgadmin 4.

How do I fix CVE-2025-12762?

Upgrade pgadmin4 to 9.10 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-12762 being exploited?

There is no known exploitation of CVE-2025-12762 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-w2p4-p4rh-qcm3, PYSEC-2026-454.

Is CVE-2025-12762 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free