{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12762 in the wild and no public exploit code.","fix":"Upgrade pgadmin4 to 9.10 or later.","what":"CVE-2025-12762 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12762 and fix it if it is affected.\n\nWhat it is: CVE-2025-12762 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12762 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 9.10\n- pgadmin4 (PyPI): affected all versions; fixed in 9.10\n- pgadmin4 (PyPI): affected all versions; fixed in 9.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12762/ (Markdown: https://insights.sbomify.com/CVE-2025-12762/index.md)","id":"CVE-2025-12762","markdown":"https://insights.sbomify.com/CVE-2025-12762/index.md","name":"CVE-2025-12762","record":{"aliases":["GHSA-w2p4-p4rh-qcm3","PYSEC-2026-454"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL management tool","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands on the server by restoring malicious PLAIN-format SQL dumps in pgAdmin 4 server mode.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2025-11-24","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-11-24T07:18:09Z","kind":"github_poc","ref":"https://github.com/djayaGit/Blackash-CVE-2025-12762","stars":0,"title":"CVE-2025-12762"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)","id":"CVE-2025-12762","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Command injection vulnerability allowing arbitrary command execution on Windows","id":"CVE-2025-12763"},"packages":[{"ecosystem":"PyPI","fixed":["9.10"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-w2p4-p4rh-qcm3"},{"ecosystem":"PyPI","fixed":["9.10"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-w2p4-p4rh-qcm3"},{"ecosystem":"PyPI","fixed":["9.10"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-454"}],"prev":{"headline":"Simple multi step form - Moderately critical - Cross-site Scripting - SA-CONTRIB-2025-116","id":"CVE-2025-12761"},"products":["pgAdmin 4"],"published":"2025-11-13","related":[{"cvss_score":9.9,"headline":"pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment","id":"CVE-2025-2945","kev_date_added":null,"published":"2025-04-03"},{"cvss_score":9.9,"headline":"OAuth2 client id and secret exposed through the web browser in pgAdmin 4","id":"CVE-2024-9014","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9.5,"headline":"Deserialization in pgAdmin 4","id":"CVE-2026-12046","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"SQL injection in pgAdmin 4","id":"CVE-2026-17351","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"Command injection in pgAdmin 4","id":"CVE-2026-17566","kev_date_added":null,"published":"2026-07-31"},{"cvss_score":9.4,"headline":"pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution","id":"CVE-2026-12045","kev_date_added":null,"published":"2026-06-18"},{"cvss_score":9.4,"headline":"pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode","id":"CVE-2026-7813","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["pgadmin.org"]},"summary":"Attackers can execute arbitrary commands on the server by restoring malicious PLAIN-format SQL dumps in pgAdmin 4 server mode.","url":"https://insights.sbomify.com/CVE-2025-12762/"}