# CVE-2025-12762: Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)

> Attackers can execute arbitrary commands on the server by restoring malicious PLAIN-format SQL dumps in pgAdmin 4 server mode.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-w2p4-p4rh-qcm3, PYSEC-2026-454

## What is CVE-2025-12762?

CVE-2025-12762 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-12762?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.10 |
| `pgadmin4` | PyPI | All versions | 9.10 |
| `pgadmin4` | PyPI | All versions | 9.10 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2025-12762?

Upgrade pgadmin4 to 9.10 or later.

## Is CVE-2025-12762 being exploited?

There is no known exploitation of CVE-2025-12762 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-12762 (github_poc): https://github.com/djayaGit/Blackash-CVE-2025-12762

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12762 and fix it if it is affected.

What it is: CVE-2025-12762 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12762 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.10
- pgadmin4 (PyPI): affected all versions; fixed in 9.10
- pgadmin4 (PyPI): affected all versions; fixed in 9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12762/ (Markdown: https://insights.sbomify.com/CVE-2025-12762/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12762
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12762
- OSV: https://osv.dev/vulnerability/CVE-2025-12762

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12762/
Summaries are generated and may contain mistakes; the official description above is the record.
