# CVE-2025-12764: pgAdmin 4: LDAP injection vulnerability in LDAP authentication flow.

> Attackers can cause denial of service in pgAdmin 4 by injecting LDAP characters during authentication when LDAP is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2025
- **Updated:** 13 Nov 2025
- **Also known as:** GHSA-cvf4-f829-762v, PYSEC-2026-1772

## What is CVE-2025-12764?

CVE-2025-12764 is a high-severity vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pgAdmin <= 9.9  is affected by an LDAP injection vulnerability in the LDAP authentication flow that allows an attacker to inject special LDAP characters in the username, causing the DC/LDAP server and the client to process an unusual amount of data DOS.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2025-12764?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.10 |
| `pgadmin4` | PyPI | All versions | 9.10 |
| `pgadmin4` | PyPI | All versions | 9.10 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2025-12764?

Upgrade pgadmin4 to 9.10 or later.

## Is CVE-2025-12764 being exploited?

There is no known exploitation of CVE-2025-12764 in the wild and no public exploit code.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12764 and fix it if it is affected.

What it is: CVE-2025-12764 is a high-severity vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12764 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.10
- pgadmin4 (PyPI): affected all versions; fixed in 9.10
- pgadmin4 (PyPI): affected all versions; fixed in 9.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12764/ (Markdown: https://insights.sbomify.com/CVE-2025-12764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12764
- OSV: https://osv.dev/vulnerability/CVE-2025-12764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12764/
Summaries are generated and may contain mistakes; the official description above is the record.
