CVE-2025-12765 pgAdmin 4: LDAP authentication flow vulnerable to TLS certificate verification bypass.

High 7.5 Published Updated

Attackers can bypass TLS certificate verification in pgAdmin 4's LDAP authentication, potentially enabling man-in-the-middle attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12765?

CVE-2025-12765 is a high-severity vulnerability in pgadmin.org pgAdmin 4, published on 13 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

pgAdmin <= 9.9  is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.

Weakness: CWE-295

Which versions are affected by CVE-2025-12765?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.

PackageAffectedFixed in
pgadmin4 PyPIAll versions9.10
pgadmin4 PyPIAll versions9.10
pgadmin4 PyPIAll versions9.10

Products include Pgadmin Pgadmin 4.

How do I fix CVE-2025-12765?

Upgrade pgadmin4 to 9.10 or later.

Is CVE-2025-12765 being exploited?

There is no known exploitation of CVE-2025-12765 in the wild and no public exploit code.

Sources

Also known as GHSA-g4r8-3qmh-pmch, PYSEC-2026-1773.

Is CVE-2025-12765 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free