# CVE-2025-12811: Cloud Suite and Privilege Access Service– HTTP request smuggling vulnerability

> Attackers can exploit HTTP request smuggling in Delinea Cloud Suite to bypass security controls or access sensitive data.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Feb 2026
- **Updated:** 19 Feb 2026
- **Also known as:** GHSA-654q-5mj4-74h4

## What is CVE-2025-12811?

CVE-2025-12811 is a medium-severity vulnerability in Delinea Inc. Cloud Suite and Privileged Access Service, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Inconsistent Interpretation of
HTTP Requests ('HTTP Request Smuggling') in Delinea Inc. Cloud Suite and
Privileged Access Service.

If you're not using the latest Server Suite agents, this fix requires that you upgrade to Server Suite 2023.1 (agent 6.0.1) or later.  *  If you cannot upgrade to Release 2023.1 (agent version 6.0.1) or later, you can choose one of the following versions:

  *  Server Suite release 2023.0.5 (agent version 6.0.0-158)

  *  Server Suite release 2022.1.10 (agent version 5.9.1-337)

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-12811?


## How do I fix CVE-2025-12811?

No fix has been published for CVE-2025-12811 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-12811 being exploited?

There is no known exploitation of CVE-2025-12811 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12811 and fix it if it is affected.

What it is: CVE-2025-12811 is a medium-severity vulnerability in Delinea Inc. Cloud Suite and Privileged Access Service, published on 18 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12811 in the wild and no public exploit code.

Affected product: Delinea Inc. Cloud Suite and Privileged Access Service. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12811/ (Markdown: https://insights.sbomify.com/CVE-2025-12811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12811
- OSV: https://osv.dev/vulnerability/CVE-2025-12811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12811/
Summaries are generated and may contain mistakes; the official description above is the record.
