CVE-2025-12817 PostgreSQL CREATE STATISTICS does not check for schema CREATE privilege
A table owner can cause denial of service against other users by creating statistics in any schema without proper privilege checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-12817?
CVE-2025-12817 is a low-severity missing authorization vulnerability in PostgreSQL, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema. A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.
Weakness: CWE-862
Which versions are affected by CVE-2025-12817?
1 open source package ship an affected version, including postgresql.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 13.23.0, 14.20.0, 15.15.0, 16.11.0, 17.7.0, 18.1.0 |
How do I fix CVE-2025-12817?
Upgrade postgresql to a fixed version for your release line: 13.23.0, 14.20.0, 15.15.0 or 16.11.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-12817 being exploited?
There is no known exploitation of CVE-2025-12817 in the wild and no public exploit code.
Sources
Also known as ALPINE-CVE-2025-12817, AZL-70169, AZL-70396, BELL-CVE-2025-12817, BIT-postgresql-2025-12817, CLEANSTART-2026-RW68010 and 11 more.