{"answers":{"affected":"1 open source package ship an affected version, including postgresql.","exploited":"There is no known exploitation of CVE-2025-12817 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 13.23.0, 14.20.0, 15.15.0 or 16.11.0.","what":"CVE-2025-12817 is a low-severity missing authorization vulnerability in PostgreSQL, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12817 and fix it if it is affected.\n\nWhat it is: CVE-2025-12817 is a low-severity missing authorization vulnerability in PostgreSQL, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12817 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected all versions; fixed in 13.23.0, 14.20.0, 15.15.0, 16.11.0, 17.7.0, 18.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12817/ (Markdown: https://insights.sbomify.com/CVE-2025-12817/index.md)","id":"CVE-2025-12817","markdown":"https://insights.sbomify.com/CVE-2025-12817/index.md","name":"CVE-2025-12817","record":{"aliases":["ALPINE-CVE-2025-12817","AZL-70169","AZL-70396","BELL-CVE-2025-12817","BIT-postgresql-2025-12817","CLEANSTART-2026-RW68010","CLSA-2026-1769516785","DEBIAN-CVE-2025-12817","ECHO-e69d-d943-6623","GHSA-99qj-9hw7-85x8","MINI-6jcf-cq98-c8q5","MINI-74rp-2x93-54hv","MINI-89cp-rrww-4f43","MINI-hf82-3x7f-m637","MINI-rmx2-74jj-wxp7","MINI-x7vx-2cmx-7mj5","UBUNTU-CVE-2025-12817"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"low_privilege","summary":"A table owner can cause denial of service against other users by creating statistics in any schema without proper privilege checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema.  A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail.  Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL CREATE STATISTICS does not check for schema CREATE privilege","id":"CVE-2025-12817","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL libpq undersizes allocations, via integer wraparound","id":"CVE-2025-12818"},"packages":[{"ecosystem":"Bitnami","fixed":["13.23.0","14.20.0","15.15.0","16.11.0","17.7.0","18.1.0"],"introduced":["0","14.0.0","15.0.0","16.0.0","17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2025-12817"}],"prev":{"headline":"CVE-2025-12816","id":"CVE-2025-12816"},"products":["PostgreSQL"],"published":"2025-11-13","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-13","vendors":["n/a"]},"summary":"A table owner can cause denial of service against other users by creating statistics in any schema without proper privilege checks.","url":"https://insights.sbomify.com/CVE-2025-12817/"}