# CVE-2025-12829: Information disclosure in Ion-C

> An attacker can craft data to expose sensitive memory contents via UTF-8 escape sequences in Amazon Ion-C serialization.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Nov 2025
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-7mgf-6x73-5h7r

## What is CVE-2025-12829?

CVE-2025-12829 is a medium-severity vulnerability in Amazon Ion-C, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An uninitialized stack read issue exists in Amazon Ion-C versions <v1.1.4 that may allow a threat actor to craft data and serialize it to Ion text in such a way that sensitive data in memory could be exposed through UTF-8 escape sequences. To mitigate this issue, users should upgrade to version v1.1.4.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-12829?


## How do I fix CVE-2025-12829?

No fix has been published for CVE-2025-12829 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-12829 being exploited?

There is no known exploitation of CVE-2025-12829 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12829 and fix it if it is affected.

What it is: CVE-2025-12829 is a medium-severity vulnerability in Amazon Ion-C, published on 7 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12829 in the wild and no public exploit code.

Affected product: Amazon Ion-C. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12829/ (Markdown: https://insights.sbomify.com/CVE-2025-12829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12829
- OSV: https://osv.dev/vulnerability/CVE-2025-12829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12829/
Summaries are generated and may contain mistakes; the official description above is the record.
