{"answers":{"affected":"1 open source package ship an affected version, including mongodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12893 in the wild and no public exploit code.","fix":"Upgrade mongodb to a fixed version for your release line: 7.0.26, 8.0.16 or 8.2.2.","what":"CVE-2025-12893 is a low-severity vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12893 and fix it if it is affected.\n\nWhat it is: CVE-2025-12893 is a low-severity vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12893 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.26, 8.0.16, 8.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12893/ (Markdown: https://insights.sbomify.com/CVE-2025-12893/index.md)","id":"CVE-2025-12893","markdown":"https://insights.sbomify.com/CVE-2025-12893/index.md","name":"CVE-2025-12893","record":{"aliases":["BIT-mongodb-2025-12893","GHSA-wj7q-322r-2rrc","MINI-cx34-rxww-2wcw","MINI-pvm8-h8fj-vv54"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MongoDB Server","requires_auth":"low_privilege","summary":"Attackers can bypass TLS certificate validation on Windows or Apple MongoDB servers by using certificates with missing Extended Key Usage fields.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mongodb","cpe":[{"product":"mongodb","vendor":"mongodb"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Clients may successfully perform a TLS handshake with a MongoDB server despite presenting a client certificate not aligning with the documented Extended Key Usage (EKU) requirements. A certificate that specifies extendedKeyUsage but is missing extendedKeyUsage = clientAuth may still be successfully authenticated via the TLS handshake as a client. This issue is specific to MongoDB servers running on Windows or Apple as the expected validation behavior functions correctly on Linux systems.\n\nAdditionally, MongoDB servers may successfully establish egress TLS connections with servers that present server certificates not aligning with the documented Extended Key Usage (EKU) requirements. A certificate that specifies extendedKeyUsage but is missing extendedKeyUsage = serverAuth may still be successfully authenticated via the TLS handshake as a server. This issue is specific to MongoDB servers running on Apple as the expected validation behavior functions correctly on both Linux and Windows systems. \n\nThis vulnerability affects MongoDB Server v7.0 versions prior to 7.0.26, MongoDB Server v8.0 versions prior to 8.0.16 and MongoDB Server v8.2 versions prior to 8.2.2","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in MongoDB Server","id":"CVE-2025-12893","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mongodb:mongodb","products":["mongodb:mongodb"],"type":"security_feature_bypass","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Import WP – Export and Import CSV and XML files to WordPress \u003c= 2.14.17 - Unauthenticated Information Exposure","id":"CVE-2025-12894"},"packages":[{"ecosystem":"Bitnami","fixed":["7.0.26","8.0.16","8.2.2"],"introduced":["7.0.0","8.0.0","8.2.0"],"last_affected":[],"package":"mongodb","purl":"pkg:bitnami/mongodb","source":"BIT-mongodb-2025-12893"}],"prev":{"headline":"Survey Maker \u003c= 5.1.9.4 - Missing Authorization to Unauthenticated Limited Option Update","id":"CVE-2025-12892"},"products":["MongoDB Server"],"published":"2025-11-25","related":[{"cvss_score":8.7,"headline":"MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency","id":"CVE-2025-14847","kev_date_added":"2025-12-29","published":"2025-12-19"},{"cvss_score":9.2,"headline":"Auth bypass in MongoDB Server","id":"CVE-2026-82067","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption","id":"CVE-2026-13072","kev_date_added":null,"published":"2026-07-22"},{"cvss_score":9.1,"headline":"Denial of service in n/a","id":"CVE-2017-15535","kev_date_added":null,"published":"2017-11-01"},{"cvss_score":9,"headline":"Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure","id":"CVE-2026-18691","kev_date_added":null,"published":"2026-08-11"},{"cvss_score":8.8,"headline":"MongoDB Server may allow successful untrusted connection","id":"CVE-2024-1351","kev_date_added":null,"published":"2024-03-07"},{"cvss_score":8.7,"headline":"Denial of service in MongoDB Server","id":"CVE-2026-82064","kev_date_added":null,"published":"2026-09-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-25","vendors":["MongoDB Inc."]},"summary":"Attackers can bypass TLS certificate validation on Windows or Apple MongoDB servers by using certificates with missing Extended Key Usage fields.","url":"https://insights.sbomify.com/CVE-2025-12893/"}