# CVE-2025-12893: Security feature bypass in MongoDB Server

> Attackers can bypass TLS certificate validation on Windows or Apple MongoDB servers by using certificates with missing Extended Key Usage fields.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** BIT-mongodb-2025-12893, GHSA-wj7q-322r-2rrc, MINI-cx34-rxww-2wcw, MINI-pvm8-h8fj-vv54

## What is CVE-2025-12893?

CVE-2025-12893 is a low-severity vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Clients may successfully perform a TLS handshake with a MongoDB server despite presenting a client certificate not aligning with the documented Extended Key Usage (EKU) requirements. A certificate that specifies extendedKeyUsage but is missing extendedKeyUsage = clientAuth may still be successfully authenticated via the TLS handshake as a client. This issue is specific to MongoDB servers running on Windows or Apple as the expected validation behavior functions correctly on Linux systems.

Additionally, MongoDB servers may successfully establish egress TLS connections with servers that present server certificates not aligning with the documented Extended Key Usage (EKU) requirements. A certificate that specifies extendedKeyUsage but is missing extendedKeyUsage = serverAuth may still be successfully authenticated via the TLS handshake as a server. This issue is specific to MongoDB servers running on Apple as the expected validation behavior functions correctly on both Linux and Windows systems. 

This vulnerability affects MongoDB Server v7.0 versions prior to 7.0.26, MongoDB Server v8.0 versions prior to 8.0.16 and MongoDB Server v8.2 versions prior to 8.2.2

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-12893?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 7.0.0 | 7.0.26, 8.0.16, 8.2.2 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-12893?

Upgrade mongodb to a fixed version for your release line: 7.0.26, 8.0.16 or 8.2.2.

## Is CVE-2025-12893 being exploited?

There is no known exploitation of CVE-2025-12893 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12893 and fix it if it is affected.

What it is: CVE-2025-12893 is a low-severity vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12893 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 7.0.0; fixed in 7.0.26, 8.0.16, 8.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12893/ (Markdown: https://insights.sbomify.com/CVE-2025-12893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12893
- OSV: https://osv.dev/vulnerability/CVE-2025-12893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12893/
Summaries are generated and may contain mistakes; the official description above is the record.
