CVE-2025-12914 aaPanel BaoTa Backend database sql injection

Medium 5.1 Published Updated

Remote attackers can exploit SQL injection in aaPanel BaoTa backend to read or modify database contents.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-12914?

CVE-2025-12914 is a medium-severity SQL injection vulnerability in aaPanel BaoTa, published on 8 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability has been found in aaPanel BaoTa up to 11.2.x. This vulnerability affects unknown code of the file /database?action=GetDatabaseAccess of the component Backend. The manipulation of the argument Name leads to sql injection. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 11.3.0 is able to resolve this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89, CWE-74

Which versions are affected by CVE-2025-12914?

How do I fix CVE-2025-12914?

No fix has been published for CVE-2025-12914 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-12914 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-12914 exists.

Sources

Also known as GHSA-88w2-6722-q9jg.

Is CVE-2025-12914 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free