# CVE-2025-1293: HashiCorp Hermes Improperly Validates AWS ALB JWTs, which May Lead to Authentication Bypass

> Attackers can bypass authentication in HashiCorp Hermes when using AWS ALB mode due to improper JWT validation.

- **Severity:** High 8.2 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2025
- **Updated:** 20 Feb 2025
- **Also known as:** GHSA-vxm9-8mfw-vc6g, GO-2025-3475

## What is CVE-2025-1293?

CVE-2025-1293 is a high-severity authentication bypass vulnerability in HashiCorp Tooling, published on 20 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Hermes versions up to 0.4.0 improperly validated the JWT provided when using the AWS ALB authentication mode, potentially allowing for authentication bypass. This vulnerability, CVE-2025-1293, was fixed in Hermes 0.5.0.

Weakness: CWE-1390 (Weak Authentication)

## Which versions are affected by CVE-2025-1293?

3 open source packages ship an affected version, including github.com/hashicorp-forge/hermes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp-forge/hermes` | Go | All versions | 0.5.0 |
| `github.com/hashicorp-forge/hermes` | Go | All versions | 0.5.0 |
| `github.com/hashicorp-forge/hermes` | Go | All versions | 0.5.0 |

Products: Hashicorp Hermes.

## How do I fix CVE-2025-1293?

Upgrade github.com/hashicorp-forge/hermes to 0.5.0 or later.

## Is CVE-2025-1293 being exploited?

There is no known exploitation of CVE-2025-1293 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1293 and fix it if it is affected.

What it is: CVE-2025-1293 is a high-severity authentication bypass vulnerability in HashiCorp Tooling, published on 20 Feb 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1293 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp-forge/hermes (Go): affected all versions; fixed in 0.5.0
- github.com/hashicorp-forge/hermes (Go): affected all versions; fixed in 0.5.0
- github.com/hashicorp-forge/hermes (Go): affected all versions; fixed in 0.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1293/ (Markdown: https://insights.sbomify.com/CVE-2025-1293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1293
- OSV: https://osv.dev/vulnerability/CVE-2025-1293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1293/
Summaries are generated and may contain mistakes; the official description above is the record.
