{"answers":{"affected":"3 open source packages ship an affected version, including aws-advanced-python-wrapper and aws_advanced_python_wrapper.","exploited":"There is no known exploitation of CVE-2025-12967 in the wild and no public exploit code.","fix":"Upgrade aws-advanced-python-wrapper to 1.4.0 or later.","what":"CVE-2025-12967 is a high-severity vulnerability in AWS Go Wrapper, published on 10 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-12967 and fix it if it is affected.\n\nWhat it is: CVE-2025-12967 is a high-severity vulnerability in AWS Go Wrapper, published on 10 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-12967 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-advanced-python-wrapper (PyPI): affected all versions; fixed in 1.4.0\n- aws-advanced-python-wrapper (PyPI): affected all versions; fixed in 1.4.0\n- aws_advanced_python_wrapper (PyPI): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12967/ (Markdown: https://insights.sbomify.com/CVE-2025-12967/index.md)","id":"CVE-2025-12967","markdown":"https://insights.sbomify.com/CVE-2025-12967/index.md","name":"CVE-2025-12967","record":{"aliases":["GHSA-4jvf-wx3f-2x8q","PYSEC-2026-1205"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS database wrappers","requires_auth":"low_privilege","summary":"Low-privilege users can escalate to rds_superuser via crafted functions in AWS database wrappers, requiring an upgrade to secure versions.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.\n\nWe recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance","id":"CVE-2025-12967","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":3,"n_references":11,"next":{"headline":"Infility Global \u003c= 2.14.42 - Authenticated (Subscriber+) Arbitrary File Upload","id":"CVE-2025-12968"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"aws-advanced-python-wrapper","purl":"pkg:pypi/aws-advanced-python-wrapper","source":"GHSA-4jvf-wx3f-2x8q"},{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"aws-advanced-python-wrapper","purl":"pkg:pypi/aws-advanced-python-wrapper","source":"PYSEC-2026-1205"},{"ecosystem":"PyPI","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"aws_advanced_python_wrapper","purl":null,"source":"GHSA-4jvf-wx3f-2x8q"}],"prev":{"headline":"All-in-One Video Gallery 4.5.4 - 4.5.7 – Authenticated (Author+) Arbitrary File Upload via Import ZIP","id":"CVE-2025-12966"},"products":["Go Wrapper","JDBC Wrapper","NodeJS Wrapper","ODBC driver","Python Wrapper"],"published":"2025-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-26","vendors":["AWS"]},"summary":"Low-privilege users can escalate to rds_superuser via crafted functions in AWS database wrappers, requiring an upgrade to secure versions.","url":"https://insights.sbomify.com/CVE-2025-12967/"}