# CVE-2025-12967: AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance

> Low-privilege users can escalate to rds_superuser via crafted functions in AWS database wrappers, requiring an upgrade to secure versions.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-4jvf-wx3f-2x8q, PYSEC-2026-1205

## What is CVE-2025-12967?

CVE-2025-12967 is a high-severity vulnerability in AWS Go Wrapper, published on 10 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.

We recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2025-12967?

3 open source packages ship an affected version, including aws-advanced-python-wrapper and aws_advanced_python_wrapper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-advanced-python-wrapper` | PyPI | All versions | 1.4.0 |
| `aws-advanced-python-wrapper` | PyPI | All versions | 1.4.0 |
| `aws_advanced_python_wrapper` | PyPI | All versions | 1.4.0 |

## How do I fix CVE-2025-12967?

Upgrade aws-advanced-python-wrapper to 1.4.0 or later.

## Is CVE-2025-12967 being exploited?

There is no known exploitation of CVE-2025-12967 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12967 and fix it if it is affected.

What it is: CVE-2025-12967 is a high-severity vulnerability in AWS Go Wrapper, published on 10 Nov 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-12967 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-advanced-python-wrapper (PyPI): affected all versions; fixed in 1.4.0
- aws-advanced-python-wrapper (PyPI): affected all versions; fixed in 1.4.0
- aws_advanced_python_wrapper (PyPI): affected all versions; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12967/ (Markdown: https://insights.sbomify.com/CVE-2025-12967/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12967
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12967
- OSV: https://osv.dev/vulnerability/CVE-2025-12967

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12967/
Summaries are generated and may contain mistakes; the official description above is the record.
