{"answers":{"affected":"1 open source package ship an affected version, including fluent-bit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-12969 in the wild and no public exploit code.","fix":"Upgrade fluent-bit to 4.1.1 or later.","what":"CVE-2025-12969 is a medium-severity authentication bypass vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-12969 and fix it if it is affected.\n\nWhat it is: CVE-2025-12969 is a medium-severity authentication bypass vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-12969 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fluent-bit (Bitnami): affected from 4.1.0; fixed in 4.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-12969/ (Markdown: https://insights.sbomify.com/CVE-2025-12969/index.md)","id":"CVE-2025-12969","markdown":"https://insights.sbomify.com/CVE-2025-12969/index.md","name":"CVE-2025-12969","record":{"aliases":["AZL-71077","AZL-71108","BIT-fluent-bit-2025-12969","GHSA-2949-r76x-4vc4"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Fluent Bit log processor","requires_auth":"none","summary":"Remote attackers can bypass authentication in Fluent Bit's forward input plugin to inject forged logs and manipulate routing when specific configurations are used.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[{"product":"fluent_bit","vendor":"treasuredata"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Fluent Bit in_forward input plugin does not properly enforce the security.users authentication mechanism under certain configuration conditions. This allows remote attackers with network access to the Fluent Bit instance exposing the forward input to send unauthenticated data. By bypassing authentication controls, attackers can inject forged log records, flood alerting systems, or manipulate routing decisions, compromising the authenticity and integrity of ingested logs.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CVE-2025-12969","id":"CVE-2025-12969","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"CVE-2025-12970","id":"CVE-2025-12970"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.1"],"introduced":["4.1.0"],"last_affected":[],"package":"fluent-bit","purl":"pkg:bitnami/fluent-bit","source":"BIT-fluent-bit-2025-12969"}],"prev":{"headline":"Infility Global \u003c= 2.14.42 - Authenticated (Subscriber+) Arbitrary File Upload","id":"CVE-2025-12968"},"products":["Fluent Bit"],"published":"2025-11-24","related":[{"cvss_score":9.8,"headline":"Fluent Bit Memory Corruption Vulnerability","id":"CVE-2024-4323","kev_date_added":null,"published":"2024-05-20"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2021-36088","kev_date_added":null,"published":"2021-07-01"},{"cvss_score":9.1,"headline":"CVE-2025-12977","id":"CVE-2025-12977","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":8.8,"headline":"CVE-2025-12970","id":"CVE-2025-12970","kev_date_added":null,"published":"2025-11-24"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2021-46878","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2021-46879","kev_date_added":null,"published":"2023-04-11"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2020-35963","kev_date_added":null,"published":"2021-01-03"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-07","vendors":["FluentBit"]},"summary":"Remote attackers can bypass authentication in Fluent Bit's forward input plugin to inject forged logs and manipulate routing when specific configurations are used.","url":"https://insights.sbomify.com/CVE-2025-12969/"}