# CVE-2025-12969: CVE-2025-12969

> Remote attackers can bypass authentication in Fluent Bit's forward input plugin to inject forged logs and manipulate routing when specific configurations are used.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 7 Jan 2026
- **Also known as:** AZL-71077, AZL-71108, BIT-fluent-bit-2025-12969, GHSA-2949-r76x-4vc4

## What is CVE-2025-12969?

CVE-2025-12969 is a medium-severity authentication bypass vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluent Bit in_forward input plugin does not properly enforce the security.users authentication mechanism under certain configuration conditions. This allows remote attackers with network access to the Fluent Bit instance exposing the forward input to send unauthenticated data. By bypassing authentication controls, attackers can inject forged log records, flood alerting systems, or manipulate routing decisions, compromising the authenticity and integrity of ingested logs.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-12969?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 4.1.0 | 4.1.1 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2025-12969?

Upgrade fluent-bit to 4.1.1 or later.

## Is CVE-2025-12969 being exploited?

There is no known exploitation of CVE-2025-12969 in the wild and no public exploit code.

## Other vulnerabilities in FluentBit Fluent Bit

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12969 and fix it if it is affected.

What it is: CVE-2025-12969 is a medium-severity authentication bypass vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12969 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 4.1.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12969/ (Markdown: https://insights.sbomify.com/CVE-2025-12969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12969
- OSV: https://osv.dev/vulnerability/CVE-2025-12969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12969/
Summaries are generated and may contain mistakes; the official description above is the record.
