# CVE-2025-12972: CVE-2025-12972

> Attackers can write files outside the intended directory by crafting malicious tags when the File option is omitted in the out_file plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 7 Jan 2026
- **Also known as:** BIT-fluent-bit-2025-12972, GHSA-mjmc-4hm9-g39m

## What is CVE-2025-12972?

CVE-2025-12972 is a medium-severity path traversal vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluent Bit out_file plugin does not properly sanitize tag values when deriving output file names. When the File option is omitted, the plugin uses untrusted tag input to construct file paths. This allows attackers with network access to craft tags containing path traversal sequences that cause Fluent Bit to write files outside the intended output directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-12972?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 4.1.0 | 4.1.1 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2025-12972?

Upgrade fluent-bit to 4.1.1 or later.

## Is CVE-2025-12972 being exploited?

There is no known exploitation of CVE-2025-12972 in the wild and no public exploit code.

## Other vulnerabilities in FluentBit Fluent Bit

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-12972 and fix it if it is affected.

What it is: CVE-2025-12972 is a medium-severity path traversal vulnerability in FluentBit Fluent Bit, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-12972 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 4.1.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-12972/ (Markdown: https://insights.sbomify.com/CVE-2025-12972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-12972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-12972
- OSV: https://osv.dev/vulnerability/CVE-2025-12972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-12972/
Summaries are generated and may contain mistakes; the official description above is the record.
