CVE-2025-12983 Memory Allocation with Excessive Size Value in GitLab

Low 3.5 Published Updated

An authenticated attacker can cause a denial of service in GitLab by submitting specially crafted markdown content with nested formatting patterns.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-12983?

CVE-2025-12983 is a low-severity denial of service vulnerability in Gitlab Gitlab, published on 15 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.9 before 18.3.6, 18.4 before 18.4.4, and 18.5 before 18.5.2 that could have allowed an authenticated attacker to cause a denial of service condition by submitting specially crafted markdown content with nested formatting patterns.

Weakness: CWE-789

Which versions are affected by CVE-2025-12983?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.9.018.3.6, 18.4.4, 18.5.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-12983?

Upgrade gitlab to a fixed version for your release line: 18.3.6, 18.4.4 or 18.5.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-12983 being exploited?

There is no known exploitation of CVE-2025-12983 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-12983, GHSA-9mv9-gw4x-7xw4, MINI-2gcp-8mv4-x5xm, MINI-3m2m-778g-5mm3, MINI-42mc-pgpp-58v5, MINI-77v7-33pm-h893 and 13 more.

Is CVE-2025-12983 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free