CVE-2025-1299 Missing Authorization in GitLab

Medium 4.3 Published Updated

An unauthorized user can read deployment job logs in GitLab by sending a crafted request, exposing sensitive deployment information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-1299?

CVE-2025-1299 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 24 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 18.0.5, all versions starting from 18.1 before 18.1.3, all versions starting from 18.2 before 18.2.1 that, under circumstances, could have allowed an unauthorized user to read deployment job logs by sending a crafted request.

Weakness: CWE-862

Which versions are affected by CVE-2025-1299?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.4.018.0.5, 18.1.3, 18.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-1299?

Upgrade gitlab to a fixed version for your release line: 18.0.5, 18.1.3 or 18.2.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-1299 being exploited?

There is no known exploitation of CVE-2025-1299 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-1299, GHSA-54gr-cf5g-5pjm, UBUNTU-CVE-2025-1299.

Is CVE-2025-1299 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free