CVE-2025-12998 Broken Authentication in extension “Modules” (modules)
An improper authentication flaw in the TYPO3 Modules extension allows attackers to bypass authentication controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-12998?
CVE-2025-12998 is a high-severity authentication bypass vulnerability in TYPO3 Extension "Modules", published on 12 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authentication vulnerability in TYPO3 Extension "Modules" codingms/modules.This issue affects Extension "Modules": before 4.3.11, from 5.0.0 before 5.7.4, from 6.0.0 before 6.4.2, from 7.0.0 before 7.5.5.
Weakness: CWE-287
Which versions are affected by CVE-2025-12998?
8 open source packages ship an affected version, including codingms/modules.
| Package | Affected | Fixed in |
|---|---|---|
codingms/modules Packagist | All versions | 4.3.11 |
codingms/modules Packagist | All versions | 4.3.11 |
codingms/modules Packagist | From 5.0.0 | 5.7.4 |
codingms/modules Packagist | From 5.0.0 | 5.7.4 |
codingms/modules Packagist | From 6.0.0 | 6.4.2 |
codingms/modules Packagist | From 6.0.0 | 6.4.2 |
2 more packages
codingms/modules Packagist | From 7.0.0 | 7.5.5 |
codingms/modules Packagist | From 7.0.0 | 7.5.5 |
How do I fix CVE-2025-12998?
Upgrade codingms/modules to a fixed version for your release line: 4.3.11, 5.7.4, 6.4.2 or 7.5.5.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-12998 being exploited?
There is no known exploitation of CVE-2025-12998 in the wild and no public exploit code.
Sources
Also known as GHSA-49qv-h8pm-73pf.