{"answers":{"affected":"2 open source packages ship an affected version, including jsonpath-plus.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1302 exists.","fix":"Upgrade jsonpath-plus to 10.3.0 or later.","what":"CVE-2025-1302 is a critical code injection vulnerability in jsonpath-plus, published on 15 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1302 and fix it if it is affected.\n\nWhat it is: CVE-2025-1302 is a critical code injection vulnerability in jsonpath-plus, published on 15 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1302 exists.\n\nAffected packages and fixed versions:\n- jsonpath-plus (npm): affected all versions; fixed in 10.3.0\n- jsonpath-plus (npm): affected all versions; fixed in 10.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1302/ (Markdown: https://insights.sbomify.com/CVE-2025-1302/index.md)","id":"CVE-2025-1302","markdown":"https://insights.sbomify.com/CVE-2025-1302/index.md","name":"CVE-2025-1302","record":{"aliases":["CLSA-2026-1774657371","GHSA-hw8r-x6gr-5gjp","MINI-qf95-q77j-xf3m","ROOT-APP-NPM-CVE-2025-1302"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript JSONPath library","requires_auth":"none","summary":"An attacker can execute arbitrary code on systems using the jsonpath-plus library due to improper input sanitization in safe mode.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Versions of the package jsonpath-plus before 10.3.0 are vulnerable to Remote Code Execution (RCE) due to improper input sanitization. An attacker can execute aribitrary code on the system by exploiting the unsafe default usage of eval='safe' mode.\r\r**Note:**\r\rThis is caused by an incomplete fix for [CVE-2024-21534](https://security.snyk.io/vuln/SNYK-JS-JSONPATHPLUS-7945884).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-02-25","github_poc":2,"max_poc_stars":21,"metasploit":0,"nuclei":1,"refs":[{"date":"2025-02-25T08:36:28Z","kind":"github_poc","ref":"https://github.com/EQSTLab/CVE-2025-1302","stars":21,"title":"JSONPath-plus Remote Code Execution"},{"date":"2025-07-24T17:45:36Z","kind":"github_poc","ref":"https://github.com/abrewer251/CVE-2025-1302_jsonpath-plus_RCE","stars":1,"title":"PoC exploit and vulnerable server demo for CVE-2025-1302 in jsonpath-plus."},{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-1302.yaml","stars":null,"title":"JSONPath Plus \u003c 10.3.0 - Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"JSONPath Plus allows Remote Code Execution","id":"CVE-2025-1302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Plugin Oficial – Getnet para WooCommerce \u003c= 1.7.3 - Unauthenticated Reflected XSS","id":"CVE-2025-1303"},"packages":[{"ecosystem":"npm","fixed":["10.3.0"],"introduced":["0"],"last_affected":[],"package":"jsonpath-plus","purl":null,"source":"GHSA-hw8r-x6gr-5gjp"},{"ecosystem":"npm","fixed":["10.3.0"],"introduced":["0"],"last_affected":[],"package":"jsonpath-plus","purl":"pkg:npm/jsonpath-plus","source":"GHSA-hw8r-x6gr-5gjp"}],"prev":{"headline":"Reflected XSS in Yordam Informatics' Library Automation System","id":"CVE-2025-1301"},"products":["jsonpath-plus"],"published":"2025-02-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-18","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code on systems using the jsonpath-plus library due to improper input sanitization in safe mode.","url":"https://insights.sbomify.com/CVE-2025-1302/"}