# CVE-2025-13033: Nodemailer: nodemailer: email to an unintended domain can occur due to interpretation conflict

> Attackers can misdirect emails to external addresses by crafting specific recipient formats, leading to data leaks and bypassing security filters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2025
- **Updated:** 11 May 2026
- **Also known as:** CLSA-2026-1775003162, DEBIAN-CVE-2025-13033, ECHO-23af-6658-b0f8, GHSA-mm7p-fcc7-pg87, MINI-333q-78w5-2p5w, MINI-497r-37f3-37ph, MINI-f2pm-8mc9-2jpw, MINI-fc93-rjcr-hj5x, MINI-j7x2-x6v6-cqqx, MINI-r857-hgcq-247q, MINI-rh2h-87jg-77wm, ROOT-APP-NPM-CVE-2025-13033, UBUNTU-CVE-2025-13033

## What is CVE-2025-13033?

CVE-2025-13033 is a high-severity vulnerability in Red Hat Advanced Cluster Management for Kubernetes 2, published on 14 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was identified in the email parsing library due to improper handling of specially formatted recipient email addresses. An attacker can exploit this flaw by crafting a recipient address that embeds an external address within quotes. This causes the application to misdirect the email to the attacker's external address instead of the intended internal recipient. This could lead to a significant data leak of sensitive information and allow an attacker to bypass security filters and access controls.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2025-13033?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 7.0.7 |
| `nodemailer` | npm | All versions | 7.0.7 |

## How do I fix CVE-2025-13033?

Upgrade nodemailer to 7.0.7 or later.

## Is CVE-2025-13033 being exploited?

There is no known exploitation of CVE-2025-13033 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13033 and fix it if it is affected.

What it is: CVE-2025-13033 is a high-severity vulnerability in Red Hat Advanced Cluster Management for Kubernetes 2, published on 14 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13033 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 7.0.7
- nodemailer (npm): affected all versions; fixed in 7.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13033/ (Markdown: https://insights.sbomify.com/CVE-2025-13033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13033
- OSV: https://osv.dev/vulnerability/CVE-2025-13033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13033/
Summaries are generated and may contain mistakes; the official description above is the record.
