CVE-2025-13080 Drupal core - Moderately critical - Denial of Service - SA-CORE-2025-005
An attacker can cause a denial of service in Drupal core by exploiting improper checks for unusual conditions, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-13080?
CVE-2025-13080 is a medium-severity denial of service vulnerability in Drupal Drupal, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Check for Unusual or Exceptional Conditions vulnerability in Drupal Drupal core allows Forceful Browsing.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
Weakness: CWE-754
Which versions are affected by CVE-2025-13080?
10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.5.0 | 10.5.6 |
drupal/core Packagist | From 10.5.0 | 10.5.6 |
drupal/core Packagist | From 11.0.0 | 11.1.9 |
drupal/core Packagist | From 11.0.0 | 11.1.9 |
drupal/core Packagist | From 11.2.0 | 11.2.8 |
drupal/core Packagist | From 11.2.0 | 11.2.8 |
4 more packages
drupal/core Packagist | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |
drupal/core Packagist | From 8.0.0 | 10.4.9 |
drupal/core Packagist | From 8.0.0 | 10.4.9 |
drupal Bitnami | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |
Products include Drupal Drupal.
How do I fix CVE-2025-13080?
Upgrade drupal/core to a fixed version for your release line: 10.5.6, 11.1.9, 11.2.8 or 10.4.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-13080 being exploited?
There is no known exploitation of CVE-2025-13080 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2025-13080, DRUPAL-CORE-2025-005, GHSA-83v7-c2cf-p9c2.