CVE-2025-13081 Drupal core - Moderately critical - Gadget chain - SA-CORE-2025-006

Medium 5.9 Published Updated

An attacker can exploit a gadget chain in Drupal core to achieve arbitrary code execution via object injection.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13081?

CVE-2025-13081 is a medium-severity unsafe deserialization vulnerability in Drupal Drupal, published on 18 Nov 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.

Weakness: CWE-502, CWE-915

Which versions are affected by CVE-2025-13081?

10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.

PackageAffectedFixed in
drupal/core PackagistFrom 10.5.010.5.6
drupal/core PackagistFrom 10.5.010.5.6
drupal/core PackagistFrom 11.0.011.1.9
drupal/core PackagistFrom 11.0.011.1.9
drupal/core PackagistFrom 11.2.011.2.8
drupal/core PackagistFrom 11.2.011.2.8
4 more packages
drupal/core PackagistFrom 8.0.010.4.9, 10.5.6, 11.1.9, 11.2.8
drupal/core PackagistFrom 8.0.010.4.9
drupal/core PackagistFrom 8.0.010.4.9
drupal BitnamiFrom 8.0.010.4.9, 10.5.6, 11.1.9, 11.2.8

Products include Drupal Drupal.

How do I fix CVE-2025-13081?

Upgrade drupal/core to a fixed version for your release line: 10.5.6, 11.1.9, 11.2.8 or 10.4.9.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-13081 being exploited?

There is no known exploitation of CVE-2025-13081 in the wild and no public exploit code.

All Drupal Drupal vulnerabilities

Sources

Also known as BIT-drupal-2025-13081, DRUPAL-CORE-2025-006, GHSA-m6vv-vcj8-w8m7.

Is CVE-2025-13081 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free