CVE-2025-13082 Drupal core - Moderately critical - Defacement - SA-CORE-2025-007
An attacker can spoof content in the Drupal UI, potentially misleading users and modifying displayed information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-13082?
CVE-2025-13082 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
User Interface (UI) Misrepresentation of Critical Information vulnerability in Drupal Drupal core allows Content Spoofing.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
Weakness: CWE-451
Which versions are affected by CVE-2025-13082?
10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.5.0 | 10.5.6 |
drupal/core Packagist | From 10.5.0 | 10.5.6 |
drupal/core Packagist | From 11.0.0 | 11.1.9 |
drupal/core Packagist | From 11.0.0 | 11.1.9 |
drupal/core Packagist | From 11.2.0 | 11.2.8 |
drupal/core Packagist | From 11.2.0 | 11.2.8 |
4 more packages
drupal/core Packagist | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |
drupal/core Packagist | From 8.0.0 | 10.4.9 |
drupal/core Packagist | From 8.0.0 | 10.4.9 |
drupal Bitnami | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |
Products include Drupal Drupal.
How do I fix CVE-2025-13082?
Upgrade drupal/core to a fixed version for your release line: 10.5.6, 11.1.9, 11.2.8 or 10.4.9.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-13082 being exploited?
There is no known exploitation of CVE-2025-13082 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2025-13082, DRUPAL-CORE-2025-007, GHSA-h89p-5896-f4q8.