# CVE-2025-13082: Drupal core - Moderately critical - Defacement - SA-CORE-2025-007

> An attacker can spoof content in the Drupal UI, potentially misleading users and modifying displayed information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Nov 2025
- **Updated:** 18 Nov 2025
- **Also known as:** BIT-drupal-2025-13082, DRUPAL-CORE-2025-007, GHSA-h89p-5896-f4q8

## What is CVE-2025-13082?

CVE-2025-13082 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

User Interface (UI) Misrepresentation of Critical Information vulnerability in Drupal Drupal core allows Content Spoofing.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2025-13082?

10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 10.5.0 | 10.5.6 |
| `drupal/core` | Packagist | From 10.5.0 | 10.5.6 |
| `drupal/core` | Packagist | From 11.0.0 | 11.1.9 |
| `drupal/core` | Packagist | From 11.0.0 | 11.1.9 |
| `drupal/core` | Packagist | From 11.2.0 | 11.2.8 |
| `drupal/core` | Packagist | From 11.2.0 | 11.2.8 |
| `drupal/core` | Packagist | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |
| `drupal/core` | Packagist | From 8.0.0 | 10.4.9 |
| `drupal/core` | Packagist | From 8.0.0 | 10.4.9 |
| `drupal` | Bitnami | From 8.0.0 | 10.4.9, 10.5.6, 11.1.9, 11.2.8 |

Products: Drupal Drupal.

## How do I fix CVE-2025-13082?

Upgrade drupal/core to a fixed version for your release line: 10.5.6, 11.1.9, 11.2.8 or 10.4.9.

## Is CVE-2025-13082 being exploited?

There is no known exploitation of CVE-2025-13082 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13082 and fix it if it is affected.

What it is: CVE-2025-13082 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 18 Nov 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-13082 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 10.5.0; fixed in 10.5.6
- drupal/core (Packagist): affected from 10.5.0; fixed in 10.5.6
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.1.9
- drupal/core (Packagist): affected from 11.0.0; fixed in 11.1.9
- drupal/core (Packagist): affected from 11.2.0; fixed in 11.2.8
- drupal/core (Packagist): affected from 11.2.0; fixed in 11.2.8
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.4.9, 10.5.6, 11.1.9, 11.2.8
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.4.9
- drupal/core (Packagist): affected from 8.0.0; fixed in 10.4.9
- drupal (Bitnami): affected from 8.0.0; fixed in 10.4.9, 10.5.6, 11.1.9, 11.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13082/ (Markdown: https://insights.sbomify.com/CVE-2025-13082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13082
- OSV: https://osv.dev/vulnerability/CVE-2025-13082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13082/
Summaries are generated and may contain mistakes; the official description above is the record.
