CVE-2025-13146 Contact Form 7 – Dynamic Text Extension <= 5.0.7 - Unauthenticated Arbitrary Shortcode Execution

Medium 6.5 Published Updated

Unauthenticated attackers can execute arbitrary shortcodes in the Contact Form 7 Dynamic Text Extension plugin due to improper validation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-13146?

CVE-2025-13146 is a medium-severity code injection vulnerability in sevenspark DTX – Dynamic Text Extension for Contact Form 7, published on 22 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.0.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The vulnerability was partially patched in version 5.0.4.

Weakness: CWE-94

Which versions are affected by CVE-2025-13146?

How do I fix CVE-2025-13146?

No fix has been published for CVE-2025-13146 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-13146 being exploited?

There is no known exploitation of CVE-2025-13146 in the wild and no public exploit code.

Sources

Also known as GHSA-6pxf-96xx-73mh.

Is CVE-2025-13146 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free