# CVE-2025-13192: Popup builder with Gamification <= 2.2.0 - Unauthenticated SQL Injection via Multiple REST API Endpoints

> Unauthenticated attackers can exploit SQL injection in the Popup builder with Gamification WordPress plugin to extract sensitive database information.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Feb 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-7338-r7v4-4j5w

## What is CVE-2025-13192?

CVE-2025-13192 is a high-severity SQL injection vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to generic SQL Injection via the multiple REST API endpoints in all versions up to, and including, 2.2.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query.  This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Vulnerability was patched in version 2.2.1 for unauthenticated users, and fully patched in version 2.2.3 for Administrator+ level users.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-13192?


## How do I fix CVE-2025-13192?

No fix has been published for CVE-2025-13192 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-13192 being exploited?

There is no known exploitation of CVE-2025-13192 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13192 and fix it if it is affected.

What it is: CVE-2025-13192 is a high-severity SQL injection vulnerability in roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13192 in the wild and no public exploit code.

Affected product: roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13192/ (Markdown: https://insights.sbomify.com/CVE-2025-13192/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13192
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13192
- OSV: https://osv.dev/vulnerability/CVE-2025-13192

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13192/
Summaries are generated and may contain mistakes; the official description above is the record.
