CVE-2025-13324 Lack of Invalidation of Legacy Remote Cluster Invite Tokens After Confirmation
Attackers with stolen invite tokens can authenticate as remote clusters and access shared channels due to missing token invalidation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-13324?
CVE-2025-13324 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Mattermost versions 10.11.x <= 10.11.5, 11.0.x <= 11.0.4, 10.12.x <= 10.12.2 fail to invalidate remote cluster invite tokens when using the legacy (version 1) protocol or when the confirming party does not provide a refreshed token, which allows an attacker who has obtained an invite token to authenticate as the remote cluster and perform limited actions on shared channels even after the invitation has been legitimately confirmed.
Weakness: CWE-863
Which versions are affected by CVE-2025-13324?
15 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | All versions | 11.0.4 |
github.com/mattermost/mattermost-server Go | All versions | 11.0.4 |
github.com/mattermost/mattermost-server Go | All versions | 11.0.4+incompatible |
github.com/mattermost/mattermost Go | From 10.11.0-rc1 | 10.11.5 |
github.com/mattermost/mattermost Go | From 10.11.0-rc1 | 10.11.5 |
github.com/mattermost/mattermost Go | From 10.11.0-rc1+incompatible | 10.11.5+incompatible, 10.12.2+incompatible, 11.0.4+incompatible |
9 more packages
github.com/mattermost/mattermost Go | From 10.12.0 | 10.12.2 |
github.com/mattermost/mattermost Go | From 10.12.0 | 10.12.2 |
github.com/mattermost/mattermost Go | From 11.0.0-alpha.1 | 11.0.4 |
github.com/mattermost/mattermost Go | From 11.0.0-alpha.1 | 11.0.4 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-13324?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 11.0.4 or 11.0.4+incompatible.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-13324 being exploited?
There is no known exploitation of CVE-2025-13324 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-x3r8-2hmh-89f5, GO-2025-4256.