# CVE-2025-13324: Lack of Invalidation of Legacy Remote Cluster Invite Tokens After Confirmation

> Attackers with stolen invite tokens can authenticate as remote clusters and access shared channels due to missing token invalidation.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 24 Dec 2025
- **Also known as:** GHSA-x3r8-2hmh-89f5, GO-2025-4256

## What is CVE-2025-13324?

CVE-2025-13324 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mattermost versions 10.11.x <= 10.11.5, 11.0.x <= 11.0.4, 10.12.x <= 10.12.2 fail to invalidate remote cluster invite tokens when using the legacy (version 1) protocol or when the confirming party does not provide a refreshed token, which allows an attacker who has obtained an invite token to authenticate as the remote cluster and perform limited actions on shared channels even after the invitation has been legitimately confirmed.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-13324?

15 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | 11.0.4 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 11.0.4 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 11.0.4+incompatible |
| `github.com/mattermost/mattermost` | Go | From 10.11.0-rc1 | 10.11.5 |
| `github.com/mattermost/mattermost` | Go | From 10.11.0-rc1 | 10.11.5 |
| `github.com/mattermost/mattermost` | Go | From 10.11.0-rc1+incompatible | 10.11.5+incompatible, 10.12.2+incompatible, 11.0.4+incompatible |
| `github.com/mattermost/mattermost` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost` | Go | From 10.12.0 | 10.12.2 |
| `github.com/mattermost/mattermost` | Go | From 11.0.0-alpha.1 | 11.0.4 |
| `github.com/mattermost/mattermost` | Go | From 11.0.0-alpha.1 | 11.0.4 |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20251031095924-e7e23b94e006 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-13324?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 11.0.4 or 11.0.4+incompatible.

## Is CVE-2025-13324 being exploited?

There is no known exploitation of CVE-2025-13324 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13324 and fix it if it is affected.

What it is: CVE-2025-13324 is a low-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13324 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 11.0.4
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 11.0.4
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 11.0.4+incompatible
- github.com/mattermost/mattermost (Go): affected from 10.11.0-rc1; fixed in 10.11.5
- github.com/mattermost/mattermost (Go): affected from 10.11.0-rc1; fixed in 10.11.5
- github.com/mattermost/mattermost (Go): affected from 10.11.0-rc1+incompatible; fixed in 10.11.5+incompatible, 10.12.2+incompatible, 11.0.4+incompatible
- github.com/mattermost/mattermost (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost (Go): affected from 10.12.0; fixed in 10.12.2
- github.com/mattermost/mattermost (Go): affected from 11.0.0-alpha.1; fixed in 11.0.4
- github.com/mattermost/mattermost (Go): affected from 11.0.0-alpha.1; fixed in 11.0.4
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13324/ (Markdown: https://insights.sbomify.com/CVE-2025-13324/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13324
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13324
- OSV: https://osv.dev/vulnerability/CVE-2025-13324

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13324/
Summaries are generated and may contain mistakes; the official description above is the record.
