{"answers":{"affected":"5 open source packages ship an affected version, including uv. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-13327 in the wild and no public exploit code.","fix":"Upgrade uv to 0.9.6 or later.","what":"CVE-2025-13327 is a medium-severity code injection vulnerability in Red Hat AI Inference Server, published on 27 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-13327 and fix it if it is affected.\n\nWhat it is: CVE-2025-13327 is a medium-severity code injection vulnerability in Red Hat AI Inference Server, published on 27 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-13327 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uv (PyPI): affected all versions; fixed in 0.9.6\n- uv (PyPI): affected all versions; fixed in 0.9.6\n- uv (PyPI): affected all versions; fixed in 0.9.6\n- uv (crates.io): affected all versions; fixed in 0.9.6\n- uv (crates.io): affected all versions; fixed in 0.9.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-13327/ (Markdown: https://insights.sbomify.com/CVE-2025-13327/index.md)","id":"CVE-2025-13327","markdown":"https://insights.sbomify.com/CVE-2025-13327/index.md","name":"CVE-2025-13327","record":{"aliases":["ECHO-20c9-9c83-3932","GHSA-pqhf-p39g-3x64","GHSA-v653-r55g-hcmg","MINI-x4c3-jv97-wx8x","PYSEC-2026-2295","openSUSE-SU-2026:20330-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python package installer","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary code by tricking users into installing specially crafted ZIP archives via the uv package installer.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"uv","vendor":"astral"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1286","name":"Improper Validation of Syntactic Correctness of Input"}],"description":"A flaw was found in uv. This vulnerability allows an attacker to execute malicious code during package resolution or installation via specially crafted ZIP (Zipped Information Package) archives that exploit parsing differentials, requiring user interaction to install an attacker-controlled package.","ecosystems":["PyPI","crates.io","openSUSE:Leap 16.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uv: uv: specially crafted zip archives lead to arbitrary code execution due to parsing differentials","id":"CVE-2025-13327","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":6,"n_references":8,"next":{"headline":"File Uploader for WooCommerce \u003c= 1.0.3 - Unauthenticated Arbitrary File Upload via add-image-data","id":"CVE-2025-13329"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":null,"source":"GHSA-pqhf-p39g-3x64"},{"ecosystem":"PyPI","fixed":["0.9.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"GHSA-pqhf-p39g-3x64"},{"ecosystem":"PyPI","fixed":["0.9.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:pypi/uv","source":"PYSEC-2026-2295"},{"ecosystem":"crates.io","fixed":["0.9.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":null,"source":"GHSA-v653-r55g-hcmg"},{"ecosystem":"crates.io","fixed":["0.9.6"],"introduced":["0"],"last_affected":[],"package":"uv","purl":"pkg:cargo/uv","source":"GHSA-v653-r55g-hcmg"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["0.7.18-160000.4.1"],"introduced":["0"],"last_affected":[],"package":"python-uv","purl":"pkg:rpm/opensuse/python-uv\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20330-1"}],"prev":{"headline":"Mattermost Desktop App fails to enable Hardened Runtime when packaged for Mac App Store","id":"CVE-2025-13326"},"products":["Red Hat AI Inference Server","Red Hat OpenShift AI (RHOAI)","Red Hat OpenShift AI 3.0","uv"],"published":"2026-02-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["Red Hat","astral-sh"]},"summary":"Attackers can execute arbitrary code by tricking users into installing specially crafted ZIP archives via the uv package installer.","url":"https://insights.sbomify.com/CVE-2025-13327/"}