# CVE-2025-13352: Mattermost GitHub Plugin allows unauthorized GitHub reactions via reaction forwarding hijacking

> Attackers can hijack GitHub reaction features to force users to add reactions to arbitrary GitHub objects via crafted notification posts.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** GHSA-jf5h-xfw4-p8gp, GO-2025-4247

## What is CVE-2025-13352?

CVE-2025-13352 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost versions 10.11.x <= 10.11.6 and Mattermost GitHub plugin versions <=2.4.0 fail to validate plugin bot identity in reaction forwarding which allows attackers to hijack the GitHub reaction feature to make users add reactions to arbitrary GitHub objects via crafted notification posts.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2025-13352?

14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost and github.com/mattermost/mattermost-plugin-github. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0-rc1 | 10.11.7-0.20251106103514-3b05384dd014 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.11.0-rc1 | 10.11.7-0.20251106103514-3b05384dd014 |
| `github.com/mattermost/mattermost` | Go | All versions | 10.11.7-0.20251106103514-3b05384dd014 |
| `github.com/mattermost/mattermost` | Go | All versions | 10.11.7-0.20251106103514-3b05384dd014 |
| `github.com/mattermost/mattermost` | Go | From 11.0.0-alpha.1 | 11.1.0 |
| `github.com/mattermost/mattermost` | Go | From 11.0.0-alpha.1 | 11.1.0 |
| `github.com/mattermost/mattermost` | Go | From 11.0.0-alpha.1+incompatible | 11.1.0+incompatible |
| `github.com/mattermost/mattermost-plugin-github` | Go | All versions | 1.0.1-0.20250829075715-0deffcfc6bee |
| `github.com/mattermost/mattermost-plugin-github` | Go | All versions | 1.0.1-0.20250829075715-0deffcfc6bee |
| `github.com/mattermost/mattermost-plugin-github` | Go | All versions | 1.0.1-0.20250829075715-0deffcfc6bee |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0-rc1+incompatible | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-13352?

Upgrade github.com/mattermost/mattermost/server/v8 to 10.11.7-0.20251106103514-3b05384dd014 or later.

## Is CVE-2025-13352 being exploited?

There is no known exploitation of CVE-2025-13352 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13352 and fix it if it is affected.

What it is: CVE-2025-13352 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-13352 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0-rc1; fixed in 10.11.7-0.20251106103514-3b05384dd014
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.11.0-rc1; fixed in 10.11.7-0.20251106103514-3b05384dd014
- github.com/mattermost/mattermost (Go): affected all versions; fixed in 10.11.7-0.20251106103514-3b05384dd014
- github.com/mattermost/mattermost (Go): affected all versions; fixed in 10.11.7-0.20251106103514-3b05384dd014
- github.com/mattermost/mattermost (Go): affected from 11.0.0-alpha.1; fixed in 11.1.0
- github.com/mattermost/mattermost (Go): affected from 11.0.0-alpha.1; fixed in 11.1.0
- github.com/mattermost/mattermost (Go): affected from 11.0.0-alpha.1+incompatible; fixed in 11.1.0+incompatible
- github.com/mattermost/mattermost-plugin-github (Go): affected all versions; fixed in 1.0.1-0.20250829075715-0deffcfc6bee
- github.com/mattermost/mattermost-plugin-github (Go): affected all versions; fixed in 1.0.1-0.20250829075715-0deffcfc6bee
- github.com/mattermost/mattermost-plugin-github (Go): affected all versions; fixed in 1.0.1-0.20250829075715-0deffcfc6bee
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0-rc1+incompatible; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13352/ (Markdown: https://insights.sbomify.com/CVE-2025-13352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13352
- OSV: https://osv.dev/vulnerability/CVE-2025-13352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13352/
Summaries are generated and may contain mistakes; the official description above is the record.
