# CVE-2025-13425: Denial of Service in OSV-SCALIBR

> A bug in OSV-SCALIBR causes a panic when scanning empty directories, leading to application crashes and denial of service.

- **Severity:** Low 1.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2025
- **Updated:** 20 Nov 2025
- **Also known as:** GHSA-f786-75f3-74xj, GO-2025-4149

## What is CVE-2025-13425?

CVE-2025-13425 is a low-severity vulnerability in Google OSV-SCALIBR, published on 20 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A bug in the filesystem traversal fallback path causes fs/diriterate/diriterate.go:Next() to overindex an empty slice when ReadDir returns nil for an empty directory, resulting in a panic (index out of range) and an application crash (denial of service) in OSV-SCALIBR.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-13425?

3 open source packages ship an affected version, including github.com/google/osv-scalibr.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/google/osv-scalibr` | Go | All versions | 0.3.4 |
| `github.com/google/osv-scalibr` | Go | All versions | 0.3.4 |
| `github.com/google/osv-scalibr` | Go | All versions | 0.3.4 |

## How do I fix CVE-2025-13425?

Upgrade github.com/google/osv-scalibr to 0.3.4 or later.

## Is CVE-2025-13425 being exploited?

There is no known exploitation of CVE-2025-13425 in the wild and no public exploit code.

Public exploit code:

- This repo contains instructions to reproduce CVE-2025-13425: Null Pointer dereference / Array over-indexing vulnerability that I found in Google's OSV-SCALIBR project. (github_poc): https://github.com/0xXA/google-poc

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13425 and fix it if it is affected.

What it is: CVE-2025-13425 is a low-severity vulnerability in Google OSV-SCALIBR, published on 20 Nov 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13425 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/google/osv-scalibr (Go): affected all versions; fixed in 0.3.4
- github.com/google/osv-scalibr (Go): affected all versions; fixed in 0.3.4
- github.com/google/osv-scalibr (Go): affected all versions; fixed in 0.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13425/ (Markdown: https://insights.sbomify.com/CVE-2025-13425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13425
- OSV: https://osv.dev/vulnerability/CVE-2025-13425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13425/
Summaries are generated and may contain mistakes; the official description above is the record.
