{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-13428 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-13428 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-13428 is a high-severity code injection vulnerability in Google Cloud SecOps SOAR, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-13428 and fix it if it is affected.\n\nWhat it is: CVE-2025-13428 is a high-severity code injection vulnerability in Google Cloud SecOps SOAR, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-13428 in the wild and no public exploit code.\n\nAffected product: Google Cloud SecOps SOAR. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-13428/ (Markdown: https://insights.sbomify.com/CVE-2025-13428/index.md)","id":"CVE-2025-13428","markdown":"https://insights.sbomify.com/CVE-2025-13428/index.md","name":"CVE-2025-13428","record":{"aliases":["GHSA-7cf3-6632-g938"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SecOps SOAR","requires_auth":"high_privilege","summary":"Authenticated users with IDE role can achieve remote code execution by uploading malicious Python packages to the SecOps SOAR server.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GoogleCloud","cpe":[{"product":"security_operations_soar","vendor":"google"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an \"IDE role\" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise.\n\nNo customer action is required. \n\nAll customers have been automatically upgraded to the fixed version: 6.3.64 or higher.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"RCE in SecOps SOAR server via user-provided Python packages","id":"CVE-2025-13428","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"SlimStat Analytics \u003c= 5.3.1 - Authenticated (Subscriber+) SQL Injection via `args` Parameter","id":"CVE-2025-13431"},"packages":[],"prev":{"headline":"Authentication Bypass in Dialogflow CX Messenger","id":"CVE-2025-13427"},"products":["Google Cloud SecOps SOAR"],"published":"2025-12-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-12-09","vendors":["Google Cloud"]},"summary":"Authenticated users with IDE role can achieve remote code execution by uploading malicious Python packages to the SecOps SOAR server.","url":"https://insights.sbomify.com/CVE-2025-13428/"}