# CVE-2025-13428: RCE in SecOps SOAR server via user-provided Python packages

> Authenticated users with IDE role can achieve remote code execution by uploading malicious Python packages to the SecOps SOAR server.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Dec 2025
- **Updated:** 9 Dec 2025
- **Also known as:** GHSA-7cf3-6632-g938

## What is CVE-2025-13428?

CVE-2025-13428 is a high-severity code injection vulnerability in Google Cloud SecOps SOAR, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability exists in the SecOps SOAR server. The custom integrations feature allowed an authenticated user with an "IDE role" to achieve Remote Code Execution (RCE) in the server. The flaw stemmed from weak validation of uploaded Python package code. An attacker could upload a package containing a malicious setup.py file, which would execute on the server during the installation process, leading to potential server compromise.

No customer action is required. 

All customers have been automatically upgraded to the fixed version: 6.3.64 or higher.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-13428?

It affects 1 product.


Products: Google Security Operations Soar.

## How do I fix CVE-2025-13428?

No fix has been published for CVE-2025-13428 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-13428 being exploited?

There is no known exploitation of CVE-2025-13428 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13428 and fix it if it is affected.

What it is: CVE-2025-13428 is a high-severity code injection vulnerability in Google Cloud SecOps SOAR, published on 9 Dec 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13428 in the wild and no public exploit code.

Affected product: Google Cloud SecOps SOAR. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13428/ (Markdown: https://insights.sbomify.com/CVE-2025-13428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13428
- OSV: https://osv.dev/vulnerability/CVE-2025-13428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13428/
Summaries are generated and may contain mistakes; the official description above is the record.
