# CVE-2025-13437: Arbitrary node_modules Directory Deletion in Google zx

> Attackers can delete arbitrary external node_modules directories by exploiting a symlink cleanup logic error in the Google zx CLI when using the --prefer-local flag.

- **Severity:** Medium 5.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Nov 2025
- **Updated:** 20 Nov 2025
- **Also known as:** GHSA-w87r-vg9q-crqm

## What is CVE-2025-13437?

CVE-2025-13437 is a medium-severity path traversal vulnerability in Google zx, published on 20 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

When zx is invoked with --prefer-local=<path>, the CLI creates a symlink named ./node_modules pointing to <path>/node_modules. Due to a logic error in src/cli.ts (linkNodeModules / cleanup), the function returns the target path instead of the alias (symlink path). The later cleanup routine removes what it received, which deletes the target directory itself. Result: zx can delete an external <path>/node_modules outside the current working directory.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2025-13437?

2 open source packages ship an affected version, including zx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zx` | npm | All versions | 8.8.5 |
| `zx` | npm | All versions | 8.8.5 |

## How do I fix CVE-2025-13437?

Upgrade zx to 8.8.5 or later.

## Is CVE-2025-13437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-13437 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13437 and fix it if it is affected.

What it is: CVE-2025-13437 is a medium-severity path traversal vulnerability in Google zx, published on 20 Nov 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-13437 exists.

Affected packages and fixed versions:
- zx (npm): affected all versions; fixed in 8.8.5
- zx (npm): affected all versions; fixed in 8.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13437/ (Markdown: https://insights.sbomify.com/CVE-2025-13437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13437
- OSV: https://osv.dev/vulnerability/CVE-2025-13437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13437/
Summaries are generated and may contain mistakes; the official description above is the record.
