CVE-2025-13465 Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions
Attackers can delete global prototype methods via crafted paths in Lodash unset/omit, causing application instability or bypassing security checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-13465?
CVE-2025-13465 is a medium-severity vulnerability in lodash, published on 21 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
Weakness: CWE-1321
Which versions are affected by CVE-2025-13465?
8 open source packages ship an affected version, including lodash, lodash-amd and lodash-es. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
lodash npm | From 4.0.0 | 4.17.23 |
lodash npm | From 4.0.0 | 4.17.23 |
lodash-amd npm | From 4.0.0 | 4.17.23 |
lodash-amd npm | From 4.0.0 | 4.17.23 |
lodash-es npm | From 4.0.0 | 4.17.23 |
lodash-es npm | From 4.0.0 | 4.17.23 |
2 more packages
lodash.unset npm | From 4.0.0 to 4.5.2 | None |
lodash.unset npm | From 4.0.0 to 4.5.2 | None |
Linux distribution packages (32)
cockpit-ha-cluster AlmaLinux:10 | All versions | 0.12.1-1.el10_1.2 |
pcs AlmaLinux:9 | All versions | 0.11.10-1.el9_7.2 |
pcs-snmp AlmaLinux:9 | All versions | 0.11.10-1.el9_7.2 |
cockpit-ha-cluster Red Hat:enterprise_linux:10.1 | All versions | 0:0.12.1-1.el10_1.2 |
pcs Red Hat:enterprise_linux:10.1 | All versions | 0:0.12.1-1.el10_1.2 |
pcs-snmp Red Hat:enterprise_linux:10.1 | All versions | 0:0.12.1-1.el10_1.2 |
pcs Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.10-1.el9_7.2 |
pcs-snmp Red Hat:enterprise_linux:9::highavailability | All versions | 0:0.11.10-1.el9_7.2 |
pcs Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.10-1.el9_7.2 |
pcs-snmp Red Hat:enterprise_linux:9::resilientstorage | All versions | 0:0.11.10-1.el9_7.2 |
cockpit-ha-cluster Red Hat:enterprise_linux_eus:10.0 | All versions | 0:0.12.0-3.el10_0.4 |
pcs Red Hat:enterprise_linux_eus:10.0 | All versions | 0:0.12.0-3.el10_0.4 |
pcs-snmp Red Hat:enterprise_linux_eus:10.0 | All versions | 0:0.12.0-3.el10_0.4 |
pcs Red Hat:rhel_e4s:9.2::highavailability | All versions | 0:0.11.4-7.el9_2.7 |
pcs-snmp Red Hat:rhel_e4s:9.2::highavailability | All versions | 0:0.11.4-7.el9_2.7 |
pcs Red Hat:rhel_e4s:9.2::resilientstorage | All versions | 0:0.11.4-7.el9_2.7 |
pcs-snmp Red Hat:rhel_e4s:9.2::resilientstorage | All versions | 0:0.11.4-7.el9_2.7 |
pcs Red Hat:rhel_eus:9.4::highavailability | All versions | 0:0.11.7-2.el9_4.6 |
pcs-snmp Red Hat:rhel_eus:9.4::highavailability | All versions | 0:0.11.7-2.el9_4.6 |
pcs Red Hat:rhel_eus:9.4::resilientstorage | All versions | 0:0.11.7-2.el9_4.6 |
pcs-snmp Red Hat:rhel_eus:9.4::resilientstorage | All versions | 0:0.11.7-2.el9_4.6 |
pcs Red Hat:rhel_eus:9.6::highavailability | All versions | 0:0.11.9-2.el9_6.3 |
pcs-snmp Red Hat:rhel_eus:9.6::highavailability | All versions | 0:0.11.9-2.el9_6.3 |
pcs Red Hat:rhel_eus:9.6::resilientstorage | All versions | 0:0.11.9-2.el9_6.3 |
pcs-snmp Red Hat:rhel_eus:9.6::resilientstorage | All versions | 0:0.11.9-2.el9_6.3 |
pcs Rocky Linux:9 | All versions | 0:0.11.10-1.el9_7.2 |
cockpit SUSE:Linux Enterprise Micro 5.2 | All versions | 251.3-150300.6.6.1 |
cockpit-machines SUSE:Linux Enterprise Micro 5.2 | All versions | 249.1-150300.5.3.1 |
cockpit-podman SUSE:Linux Enterprise Micro 5.2 | All versions | 33-150300.6.6.1 |
cockpit SUSE:Linux Enterprise Server 16.0 | All versions | 340-160000.4.1 |
cockpit SUSE:Linux Enterprise Server 16.0 | All versions | 354-160000.1.1 |
cockpit-machines SUSE:Linux Enterprise Server 16.0 | All versions | 346-160000.1.1 |
Products include Lodash Lodash.
How do I fix CVE-2025-13465?
Upgrade lodash to 4.17.23 or later.
Is CVE-2025-13465 being exploited?
There is no known exploitation of CVE-2025-13465 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in lodash
- CVE-2026-4800 lodash vulnerable to Code Injection via `_.template` imports key names
- CVE-2020-8203 Prototype Pollution in lodash
- CVE-2021-23337 Command Injection
- CVE-2026-2950 lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`
- CVE-2019-1010266 Regular Expression Denial of Service (ReDoS) in lodash
Sources
Also known as ALSA-2026:2438, ALSA-2026:2452, CLEANSTART-2026-FE45272, CLEANSTART-2026-LS86065, DEBIAN-CVE-2025-13465, ECHO-b483-5683-d982 and 66 more.