# CVE-2025-13466: body-parser vulnerable to denial of service when url encoding is used

> An attacker can cause denial of service in applications using body-parser by sending URL-encoded requests with excessive parameters, leading to resource exhaustion.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/E:P/AU:Y`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** CLEANSTART-2026-SS80310, DEBIAN-CVE-2025-13466, GHSA-wqch-xfxh-vrr4, MINI-hfpq-8vmj-5px2, MINI-mg9m-mm9c-mr2r, MINI-rpgf-xhrq-jcc8, ROOT-APP-NPM-CVE-2025-13466, UBUNTU-CVE-2025-13466

## What is CVE-2025-13466?

CVE-2025-13466 is a medium-severity denial of service vulnerability in body-parser, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

body-parser 2.2.0 is vulnerable to denial of service due to inefficient handling of URL-encoded bodies with very large numbers of parameters. An attacker can send payloads containing thousands of parameters within the default 100KB request size limit, causing elevated CPU and memory usage. This can lead to service slowdown or partial outages under sustained malicious traffic.
This issue is addressed in version 2.2.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-13466?

2 open source packages ship an affected version, including body-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `body-parser` | npm | From 2.2.0 | 2.2.1 |
| `body-parser` | npm | From 2.2.0 | 2.2.1 |

## How do I fix CVE-2025-13466?

Upgrade body-parser to 2.2.1 or later.

## Is CVE-2025-13466 being exploited?

There is no known exploitation of CVE-2025-13466 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13466 and fix it if it is affected.

What it is: CVE-2025-13466 is a medium-severity denial of service vulnerability in body-parser, published on 24 Nov 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13466 in the wild and no public exploit code.

Affected packages and fixed versions:
- body-parser (npm): affected from 2.2.0; fixed in 2.2.1
- body-parser (npm): affected from 2.2.0; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13466/ (Markdown: https://insights.sbomify.com/CVE-2025-13466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13466
- OSV: https://osv.dev/vulnerability/CVE-2025-13466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13466/
Summaries are generated and may contain mistakes; the official description above is the record.
