# CVE-2025-13472: Missing authorization in BlazeMeter Jenkins Plugin

> Unauthenticated users could view sensitive resource identifiers like credentials and project IDs in the BlazeMeter Jenkins plugin UI.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Dec 2025
- **Updated:** 3 Dec 2025
- **Also known as:** GHSA-fxp5-37mh-vff5

## What is CVE-2025-13472?

CVE-2025-13472 is a medium-severity missing authorization vulnerability in Perforce BlazeMeter, published on 3 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A fix was made in BlazeMeter Jenkins Plugin version 4.27 to allow users only with certain permissions to see the list of available resources like credential IDs, bzm workspaces and bzm project Ids. Prior to this fix, anyone could see this list as a dropdown on the Jenkins UI.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-13472?

2 open source packages ship an affected version, including com.blazemeter.plugins:BlazeMeterJenkinsPlugin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.blazemeter.plugins:BlazeMeterJenkinsPlugin` | Maven | All versions | 4.27 |
| `com.blazemeter.plugins:BlazeMeterJenkinsPlugin` | Maven | All versions | 4.27 |

## How do I fix CVE-2025-13472?

Upgrade com.blazemeter.plugins:BlazeMeterJenkinsPlugin to 4.27 or later.

## Is CVE-2025-13472 being exploited?

There is no known exploitation of CVE-2025-13472 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13472 and fix it if it is affected.

What it is: CVE-2025-13472 is a medium-severity missing authorization vulnerability in Perforce BlazeMeter, published on 3 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13472 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.blazemeter.plugins:BlazeMeterJenkinsPlugin (Maven): affected all versions; fixed in 4.27
- com.blazemeter.plugins:BlazeMeterJenkinsPlugin (Maven): affected all versions; fixed in 4.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13472/ (Markdown: https://insights.sbomify.com/CVE-2025-13472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13472
- OSV: https://osv.dev/vulnerability/CVE-2025-13472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13472/
Summaries are generated and may contain mistakes; the official description above is the record.
