CVE-2025-13507 Time-series operations may cause internal BSON size limit to be exceed

High 7.1 Published Updated

Attackers can cause MongoDB server termination by triggering inconsistent BSON size validation in time-series operations, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13507?

CVE-2025-13507 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Inconsistent object size validation in time series processing logic may result in later processing of oversized BSON documents leading to an assert failing and process termination. This issue impacts MongoDB Server v7.0 versions prior to 7.0.26, v8.0 versions prior to 8.0.16 and MongoDB server v8.2 versions prior to 8.2.1.

Weakness: CWE-1284

Which versions are affected by CVE-2025-13507?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 7.0.07.0.26, 8.0.16, 8.2.1

Products include Mongodb Mongodb.

How do I fix CVE-2025-13507?

Upgrade mongodb to a fixed version for your release line: 7.0.26, 8.0.16 or 8.2.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-13507 being exploited?

There is no known exploitation of CVE-2025-13507 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-13507, GHSA-jq7c-628x-vm55, MINI-j37c-qgv9-4w62, MINI-qfr3-q4q2-r32g.

Is CVE-2025-13507 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free