{"answers":{"affected":"3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-confluence. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-13523 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-plugin-confluence to 1.7.0 or later.","what":"CVE-2025-13523 is a high-severity cross-site scripting vulnerability in Mattermost Confluence Plugin, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-13523 and fix it if it is affected.\n\nWhat it is: CVE-2025-13523 is a high-severity cross-site scripting vulnerability in Mattermost Confluence Plugin, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-13523 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-13523/ (Markdown: https://insights.sbomify.com/CVE-2025-13523/index.md)","id":"CVE-2025-13523","markdown":"https://insights.sbomify.com/CVE-2025-13523/index.md","name":"CVE-2025-13523","record":{"aliases":["GHSA-ffx7-34p2-vm3w","GO-2026-4456"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Confluence Plugin","requires_auth":"low_privilege","summary":"Authenticated Confluence users can execute arbitrary JavaScript in victim browsers via malicious display names in the OAuth2 flow.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"confluence","vendor":"mattermost"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Mattermost Confluence plugin version \u003c1.7.0 fails to properly escape user-controlled display names in HTML template rendering which allows authenticated Confluence users with malicious display names to execute arbitrary JavaScript in victim browsers via sending a specially crafted OAuth2 connection link that, when visited, renders the attacker's display name without proper sanitization. Mattermost Advisory ID: MMSA-2025-00557","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow","id":"CVE-2025-13523","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Information disclosure in Wickr","id":"CVE-2025-13524"},"packages":[{"ecosystem":"Go","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":null,"source":"GHSA-ffx7-34p2-vm3w"},{"ecosystem":"Go","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GHSA-ffx7-34p2-vm3w"},{"ecosystem":"Go","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GO-2026-4456"}],"prev":{"headline":"WP Status Notifier \u003c= 1.0 - Cross-Site Request Forgery to Settings Update","id":"CVE-2025-13521"},"products":["Mattermost Confluence Plugin"],"published":"2026-02-06","related":[{"cvss_score":7.5,"headline":"Unexpected input to Update Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-52931","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.5,"headline":"Unexpected input to Create Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-54525","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.2,"headline":"Unauthenticated Channel Subscription Creation in Mattermost Confluence Plugin","id":"CVE-2025-44004","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.2,"headline":"Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin","id":"CVE-2025-54478","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":6.4,"headline":"Unauthorized Subscription Edit to Confluence Space in Mattermost Confluence Plugin","id":"CVE-2025-48731","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":5.9,"headline":"Unexpected Input to Server Webhook endpoint Causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-53514","kev_date_added":null,"published":"2025-08-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-06","vendors":["Mattermost"]},"summary":"Authenticated Confluence users can execute arbitrary JavaScript in victim browsers via malicious display names in the OAuth2 flow.","url":"https://insights.sbomify.com/CVE-2025-13523/"}