# CVE-2025-13523: Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow

> Authenticated Confluence users can execute arbitrary JavaScript in victim browsers via malicious display names in the OAuth2 flow.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2026
- **Updated:** 6 Feb 2026
- **Also known as:** GHSA-ffx7-34p2-vm3w, GO-2026-4456

## What is CVE-2025-13523?

CVE-2025-13523 is a high-severity cross-site scripting vulnerability in Mattermost Confluence Plugin, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mattermost Confluence plugin version <1.7.0 fails to properly escape user-controlled display names in HTML template rendering which allows authenticated Confluence users with malicious display names to execute arbitrary JavaScript in victim browsers via sending a specially crafted OAuth2 connection link that, when visited, renders the attacker's display name without proper sanitization. Mattermost Advisory ID: MMSA-2025-00557

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-13523?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-confluence. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.7.0 |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.7.0 |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.7.0 |

Products: Mattermost Confluence.

## How do I fix CVE-2025-13523?

Upgrade github.com/mattermost/mattermost-plugin-confluence to 1.7.0 or later.

## Is CVE-2025-13523 being exploited?

There is no known exploitation of CVE-2025-13523 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Confluence Plugin

- [CVE-2025-52931](https://insights.sbomify.com/CVE-2025-52931/): Unexpected input to Update Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin (high 7.5)
- [CVE-2025-54525](https://insights.sbomify.com/CVE-2025-54525/): Unexpected input to Create Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin (high 7.5)
- [CVE-2025-44004](https://insights.sbomify.com/CVE-2025-44004/): Unauthenticated Channel Subscription Creation in Mattermost Confluence Plugin (high 7.2)
- [CVE-2025-54478](https://insights.sbomify.com/CVE-2025-54478/): Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin (high 7.2)
- [CVE-2025-48731](https://insights.sbomify.com/CVE-2025-48731/): Unauthorized Subscription Edit to Confluence Space in Mattermost Confluence Plugin (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13523 and fix it if it is affected.

What it is: CVE-2025-13523 is a high-severity cross-site scripting vulnerability in Mattermost Confluence Plugin, published on 6 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-13523 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13523/ (Markdown: https://insights.sbomify.com/CVE-2025-13523/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13523
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13523
- OSV: https://osv.dev/vulnerability/CVE-2025-13523

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13523/
Summaries are generated and may contain mistakes; the official description above is the record.
