CVE-2025-13535 Cross-site scripting in King Addons for Elementor – 80+ Elementor Widgets, 4 000+ Elementor Templates, WooCommerce, Mega Menu, Popup Builder

Medium 6.4 Published Updated

Authenticated contributors can inject arbitrary scripts via Elementor widgets, leading to code execution or account takeover when pages are viewed or edited.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-13535?

CVE-2025-13535 is a medium-severity cross-site scripting vulnerability in kingaddons King Addons for Elementor – 80+ Elementor Widgets, 4 000+ Elementor Templates, WooCommerce, Mega Menu, Popup Builder, published on 1 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The King Addons for Elementor plugin for WordPress is vulnerable to multiple Contributor+ DOM-Based Stored Cross-Site Scripting vulnerabilities in all versions up to, and including, 51.1.38. This is due to insufficient input sanitization and output escaping across multiple widgets and features. The plugin uses esc_attr() and esc_url() within JavaScript inline event handlers (onclick attributes), which allows HTML entities to be decoded by the DOM, enabling attackers to break out of the JavaScript context. Additionally, several JavaScript files use unsafe DOM manipulation methods (template literals, .html(), and window.location.href with unvalidated URLs) with user-controlled data. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts via Elementor widget settings that execute when a user accesses the injected page or when an administrator previews the page in Elementor's editor. The vulnerability was partially patched in version 5.1.51.

Weakness: CWE-79

Which versions are affected by CVE-2025-13535?

How do I fix CVE-2025-13535?

No fix has been published for CVE-2025-13535 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-13535 being exploited?

There is no known exploitation of CVE-2025-13535 in the wild and no public exploit code.

Sources

Also known as GHSA-96wm-hfgm-fcxx.

Is CVE-2025-13535 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free