# CVE-2025-13590: Authenticated arbitrary file upload via a System REST API requiring administrator permission.

> Administrators can upload arbitrary files via a REST API, potentially leading to remote code execution in WSO2 API Manager products.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-p6jf-79j3-33f3

## What is CVE-2025-13590?

CVE-2025-13590 is a critical vulnerability in Wso2 Api Manager, published on 19 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A malicious actor with administrative privileges can upload an arbitrary file to a user-controlled location within the deployment via a system REST API. Successful uploads may lead to remote code execution. 

 By leveraging the vulnerability, a malicious actor may perform Remote Code Execution by uploading a specially crafted payload.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2025-13590?

2 open source packages ship an affected version, including org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1` | Maven | All versions | 9.32.167 |
| `org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1` | Maven | All versions | 9.32.167 |

Products: Wso2 Api Control Plane, Wso2 Api Manager, Wso2 Traffic Manager, Wso2 Universal Gateway.

## How do I fix CVE-2025-13590?

Upgrade org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1 to 9.32.167 or later.

## Is CVE-2025-13590 being exploited?

There is no known exploitation of CVE-2025-13590 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2026-5430](https://insights.sbomify.com/CVE-2026-5430/): WSO2 Multiple Products Path Traversal Vulnerability (critical 10.0, exploited in the wild)
- [CVE-2026-1728](https://insights.sbomify.com/CVE-2026-1728/): Privilege Escalation via System REST APIs in Multiple WSO2 Products Permits Admin Account Takeover (critical 9.8)
- [CVE-2025-9312](https://insights.sbomify.com/CVE-2025-9312/): Improper Certificate-Based Authentication Enforcement in Multiple WSO2 Products (critical 9.8)
- [CVE-2025-10611](https://insights.sbomify.com/CVE-2025-10611/): Potential Broken Access Control in Multiple WSO2 Products via System REST APIs (critical 9.8)
- [CVE-2025-9152](https://insights.sbomify.com/CVE-2025-9152/): Improper Privilege Management in Multiple WSO2 API Manager via keymanager-operations DCR Endpoint (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13590 and fix it if it is affected.

What it is: CVE-2025-13590 is a critical vulnerability in Wso2 Api Manager, published on 19 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-13590 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1 (Maven): affected all versions; fixed in 9.32.167
- org.wso2.carbon.apimgt:org.wso2.carbon.apimgt.rest.api.admin.v1 (Maven): affected all versions; fixed in 9.32.167

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13590/ (Markdown: https://insights.sbomify.com/CVE-2025-13590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13590
- OSV: https://osv.dev/vulnerability/CVE-2025-13590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13590/
Summaries are generated and may contain mistakes; the official description above is the record.
