CVE-2025-13611 Insertion of Sensitive Information into Log File in GitLab
Authenticated users with log access can obtain sensitive tokens from GitLab log files, requiring an upgrade to remediate.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-13611?
CVE-2025-13611 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.2 before 18.5.5 and 18.6 before 18.6.3 that could have allowed an authenticated user with access to certain logs to obtain sensitive tokens under specific conditions.
Weakness: CWE-532
Which versions are affected by CVE-2025-13611?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.2.0 | 18.4.5, 18.5.3, 18.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-13611?
Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.
Is CVE-2025-13611 being exploited?
There is no known exploitation of CVE-2025-13611 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-13611, GHSA-39m5-rg2v-54h9.