# CVE-2025-13611: Insertion of Sensitive Information into Log File in GitLab

> Authenticated users with log access can obtain sensitive tokens from GitLab log files, requiring an upgrade to remediate.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2025
- **Updated:** 31 Mar 2026
- **Also known as:** BIT-gitlab-2025-13611, GHSA-39m5-rg2v-54h9

## What is CVE-2025-13611?

CVE-2025-13611 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.2 before 18.5.5 and 18.6 before 18.6.3 that could have allowed an authenticated user with access to certain logs to obtain sensitive tokens under specific conditions.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-13611?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 13.2.0 | 18.4.5, 18.5.3, 18.6.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-13611?

Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.

## Is CVE-2025-13611 being exploited?

There is no known exploitation of CVE-2025-13611 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-13611 and fix it if it is affected.

What it is: CVE-2025-13611 is a low-severity vulnerability in Gitlab Gitlab, published on 26 Nov 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-13611 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 13.2.0; fixed in 18.4.5, 18.5.3, 18.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-13611/ (Markdown: https://insights.sbomify.com/CVE-2025-13611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-13611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-13611
- OSV: https://osv.dev/vulnerability/CVE-2025-13611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-13611/
Summaries are generated and may contain mistakes; the official description above is the record.
