CVE-2025-13643 MongoDB Server may allow queries to be terminated by unauthorized users

Low 2.3 Published Updated

Unauthorized users with limited privileges can terminate other users' queries, causing denial of service in MongoDB Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-13643?

CVE-2025-13643 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A user with access to the cluster with a limited set of privilege actions may be able to terminate queries that are being executed by other users. This may cause a denial of service by preventing a fraction of queries from successfully completing. This issue affects MongoDB Server v7.0 versions prior to 7.0.26 and MongoDB Server v8.0 versions prior to 8.0.14

Weakness: CWE-862

Which versions are affected by CVE-2025-13643?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 7.0.07.0.26, 8.0.14

Products include Mongodb Mongodb.

How do I fix CVE-2025-13643?

Upgrade mongodb to a fixed version for your release line: 7.0.26 or 8.0.14.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-13643 being exploited?

There is no known exploitation of CVE-2025-13643 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-13643, GHSA-p2cp-6qqj-8xqc, MINI-gggw-j385-gv3m, MINI-p7xp-pch3-2rhm, UBUNTU-CVE-2025-13643.

Is CVE-2025-13643 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free